Redistribution de route entre RIP et OSPF 2

Les deux protocoles de routage dynamique RIPv2 et OSPF peuvent cohabiter dans un ensemble de sous-réseaux.

L’ensemble des commandes décrites ont été testées sur des routeurs Cisco, mais la syntaxe ne change pas beaucoup en général.

Soit le réseau suivant, avec pour chaque poste les adresses suivantes :

  • Poste 1 : 192.168.0.1
  • Poste 2 : 192.168.1.1
  • Poste 3 : 192.168.2.1
  • Poste 4 : 192.168.3.1
  • Poste 5 : 192.168.4.1
  • Poste 6 : 192.168.5.1

ospf_ripVoici un tableau de la configuration des interfaces de chaque routeur, (sauf le Routeur « Router7″ que je garderais pour la fin) :

Équipement

interface

Horloge

ip

masque

réseau

R1

Fa0/0 N/A 192.168.0.254 /24 192.168.0.0
S2/0 64 kbauds 10.0.0.254 /24 10.0.0.0

R2

Fa0/0 N/A 192.168.1.254 /24 192.168.1.0
S2/0 64 kbauds 10.0.0.253 /24 10.0.0.0
Fa0/1 N/A 172.17.0.253 /24 172.17.0.0

R3

Fa0/0 N/A 172.17.0.254 /24 172.17.0.0
Fa0/1 N/A 192.168.2.254 /24 192.168.2.0

Equipement

interface

Horloge

ip

masque

reseau

masque générique

R4

Fa0/0 N/A 192.168.3.254 /24 192.168.3.0 0.0.0.255
S2/0 64 kbauds 10.1.0.254 /24 10.1.0.0 0.0.0.255

R5

Fa0/0 N/A 192.168.4.254 /24 192.168.4.0 0.0.0.255
S2/0 64 kbauds 10.1.0.253 /24 10.1.0.0 0.0.0.255
Fa0/1 N/A 172.17.1.253 /24 172.17.1.0 0.0.0.255

R6

Fa0/0 N/A 172.17.1.254 /24 172.17.1.0 0.0.0.255
Fa0/1 N/A 192.168.5.254 /24 192.168.5.0 0.0.0.255

Le masque générique (aussi appelé en anglais « Wildcard mask ») est simplement l’inversion de tout les bits du masque, et on en à besoin pour définir des règles de routage avec OSPF. Un petit exemple : Pour un masque en 255.255.255.240 le masque générique est 0.0.0.15 (les bits qui étaient à zero passent à un, et vice versa)

Bien ,je considère que le routage RIPv2 et OSPF est déjà mis en place et fonctionne sur sa toile de sous réseaux correspondants :) .

Maintenant, intéressons nous à la config du « Router7″ pour que les postes 1, 2 et 2 puissent communiquer avec les 4, 5 et 6.

Equipement

interface

Horloge

ip

masque

reseau

masque générique

R7

ge0/0 N/A 10.2.0.1 /24 10.2.0.0 0.0.0.255
ge0/1 N/A 10.3.0.1 /24 10.3.0.0 0.0.0.255

Une fois les interfaces dans cette configuration, il suffit de mettre en place les règles de routages inter-protocoles dans le router7 comme suit :

conf t
router ospf 1
network 10.2.0.0 0.0.0.255 area 0
network 10.3.0.0 0.0.0.255 area 0
exit

Alors pour commencer on édite les règles OSPF d’id 1, en rajoutant deux networks dans le backbone, labélisés 0, on définit des règles de routages OSPF des deux côtés du routeur.

router rip
version 2
network 10.2.0.0
network 10.3.0.0
no auto-summary
exit

Ensuite on définit les règles RIP, de version 2, et on préciser une ligne sur laquelle on veut désactiver le résumé automatique des interfaces (que je n’ai pas trop compris :p), puis on repasse en mode configuration du terminal (conf t)

router ospf 1
redistribute rip subnets
exit

Ici on précise au protocole OSPF de redistribuer les packets qu’il recoit depuis un sous-réseau RIP, OSPF est donc maintenant copain avec RIP.

router rip
redistribute ospf 1 metric 10

Et oui, on termine avec ces deux lignes, pour que RIP connaisse aussi OSPF, et c’est dans la poche ;)

Si vos deux réseaux sont bien faits, ils devraient pouvoir communiquer entre eux maintenant, grâce à ce routeur de frontière bien configuré. J’espère que cela est assez clair, je pense avoir bien mis en avant les informations essentielles.

 

2 thoughts on “Redistribution de route entre RIP et OSPF

  1. Répondre Red déc 25, 2015 13 h 32 min

    D’ou vien Metric 10

Laisser un commentaire